Route Optimization Issues
Incident Report for FieldRoutes
Resolved
This incident has been resolved.
Posted Jul 29, 2022 - 15:05 UTC
Investigating
We are currently investigating the issues regarding route optimization.
Posted Jul 29, 2022 - 14:32 UTC
This incident affected: FieldRoutes (Optimization).