Interruptions Due to our Cloud Provider

Incident Report for FieldRoutes

Resolved

The issue has been fully resolved, and all services are now operating normally. We appreciate your patience while AWS restored full functionality. If you need further assistance, please reach out to support at support@fieldroutes.com.
Posted Oct 21, 2025 - 13:13 UTC

Monitoring

Customers may be experiencing interruptions in service due to issues with several cloud providers particularly with DNS. We have reached out to these providers and they have assured us that services are recovering and their services are restoring to normal operating levels. We are monitoring the situation and will share updates as they become available.
Posted Oct 20, 2025 - 14:03 UTC
This incident affected: FieldRoutes (FieldRoutes Web).