Intermittent Loading Issues
Incident Report for FieldRoutes
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 21:18 UTC
Update
We are continuing to investigate this issue.
Posted Apr 08, 2024 - 21:18 UTC
Investigating
Certain customers may experience slow loading when attempting to access the web and mobile apps. We are looking into this with priority.
Posted Apr 08, 2024 - 20:33 UTC