Recurring Billing is Experiencing Issues with Invoices Not Generating Correctly

Incident Report for FieldRoutes

Update

We are continuing to investigate this issue.
Posted Sep 12, 2025 - 21:15 UTC

Update

We are still actively investigating this issue.
Posted Sep 11, 2025 - 15:28 UTC

Investigating

Some databases are currently experiencing an issue where invoices are not generating as expected and/or the month advances forward without the invoice, or multiple recurring invoices are being generated. Our team is actively investigating the issue and working to restore functionality as quickly as possible. We apologize for the inconvenience and will post regular updates on our progress.

Please email: support@fieldroutes.com if you are experiencing this issue or have any additional questions.

Next Update: 9/11/25 - 9am CST
Posted Sep 10, 2025 - 20:59 UTC
This incident affects: FieldRoutes (Recurring Billing).