This issue has been resolved, and emails sent moving forward are being updated with their correct statuses. We are working with our email provider to determine if the emails that currently say 'processing' can be updated, but we also wanted to reiterate that this issue did not impact whether emails were actually delivered.
Posted Oct 30, 2025 - 18:03 UTC
Update
Our team is still working to identify why the status is not being updated.
Posted Oct 29, 2025 - 21:04 UTC
Investigating
Emails sent from the system all show a status of 'Processing' so it is difficult for users to know whether emails are being delivered. We have confirmed that this is not impacting whether emails are being delivered to their recipients. Our team is actively working to identify why the status is not being updated.
Next update: 4:00pm CDT
Posted Oct 29, 2025 - 19:04 UTC
This incident affected: FieldRoutes (Customer Communication - Email).