Unable to add Image from Phone Library in FieldRoutes Mobile
Incident Report for FieldRoutes
Resolved
This incident has been resolved.
Posted Oct 11, 2023 - 13:30 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 10, 2023 - 13:40 UTC