FieldRoutes Mobile cannot Complete Appt unless the Drop Down box is selected
Incident Report for FieldRoutes
Resolved
This incident has been resolved.
Posted Sep 27, 2023 - 21:17 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 26, 2023 - 20:04 UTC